CentOs安装node.js遇到fpu = ‘vfpv3’ if armv7 else ‘vfpv2’

1. 背景
CentOS 5.6自带的Python版本是2.4.3,但是目前许多基于Python的应用软件要求的Python版本应要高于2.4(如iotop、nodejs、func 等要求Python版本至少是2.6以上)
2. 目标
将CentOS自带的Python由2.4.3版本升级到2.7.2版本。
3. 实施
wget -c http://www.python.org/ftp/python/2.7.3/Python-2.7.3.tar.bz2
tar jxvf Python-2.7.3.tar.bz2
cd Python-2.7.3
./configure
make && make install
自此,python2.7安装后路径默认是在/usr/local/lib/python2.7
查看Python版本:
/usr/local/bin/python2.7 -V
建立软连接,使系统默认的python指向python2.7
正常情况下即使python2.7安装成功后,系统默认指向的python仍然是2.4.3版本,考虑到yum是基于python2.4.3才能正常工作,不敢轻易卸载。如何实现将系统默认的python指向到2.7版本呢?
mv /usr/bin/python /usr/bin/python.bak
ln -s /usr/local/bin/python2.7 /usr/bin/python
检验python指向是否成功
python -V
解决系统python软链接指向python2.7版本后,yum不能正常工作方法:
#vi /usr/bin/yum将第一行显示的#/usr/bin/python修改为#/usr/bin/python2.4(让yum还是去调用python2.4),保存修改即可。
sed -i ‘1s/\/usr\/bin\/python/\/usr\/bin\/python2.4/1’ /usr/bin/yum
接下来只需要正常安即可,不会再抛出fpu = ‘vfpv3’ if armv7 else ‘vfpv2’这样的错误!
参考资料:http://hxl2009.blog.51cto.com/779549/1031310
原文链接:,转发请注明来源!

发表评论