Error:Failed to resolve: com.afollestad:material-dialogs:

背景:

同事把Android项目直接考给了我。。。我在Android Studio上运行,然后提示:

Error:Failed to resolve: com.afollestad:material-dialogs:0.7.6.0

一直以为是本地依赖没有加载。。使用最新的material-dialogs版本0.8.4.2也不行。

N多坑后,发现,其实Gradle Build时会自动从https://jcenter.bintray.com/com/afollestad/material-dialogs/ 下载最新的material-dialogs,当然,是它认为最新的版本。

其实解决方式很简单。访问:https://jcenter.bintray.com/com/afollestad/material-dialogs/

里面会列出了现有的material-dialogs版本,选择你要使用的,把版本号修改到对应的bulid.gradle文件中。。重新build就可以了。。。。。

原文链接:,转发请注明来源!

发表评论